Forum

Please consider registering
guest

Log In Register

Register | Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

   

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Windows 10 64bit - 86duino zero
2015 年 12 月 20 日
13:52:05
guigra
Moderator
Forum Posts: 17
Member Since:
2014 年 02 月 15 日
Offline

Hello, i have a problem with my 86duino zero and 86duino zero.Both didn't work on Windows 10.If i connet it to my PC so i get the error unknown usb device ( errror at request of a device discription).My EDUCAKE hasn't this Problem and working very well.If is threre a 64bit driver or a work around to solve this Problem ?

Guido

2015 年 12 月 22 日
16:16:07
Android_Lin
Moderator
Forum Posts: 208
Member Since:
2014 年 04 月 01 日
Offline

Hi, Guido:

The problem may be caused by uploading a error program, you can try to update 86Duino system firmware to solve it by referring this tutorial.

Android_Lin

2015 年 12 月 27 日
23:32:28
guigra
Moderator
Forum Posts: 17
Member Since:
2014 年 02 月 15 日
Offline

Hi Andriod_Lin,

now, after your hint to this tutorial, i had followed the instuctions on this tutorial and my Zero works now very well.
The posted error is now history.Windows 10 64 bit recognized the Zero now as an serial device on comport 6.
Thanks for your help.Smile

Guido

2016 年 01 月 09 日
23:47:03
guigra
Moderator
Forum Posts: 17
Member Since:
2014 年 02 月 15 日
Offline

Hi Android_Lin,

since a few days i have same problem as in my first posting.But now can't windows 10 64bit recognized the Educake, Zero and One.Windows says : unkowned usb device ( Error at request a device description).I have no clue why it was'nt recognized as serial device as before.Today i had tryed again with the tutorial but no chance.
I've contacted the microsoft support via phone call to this problem.They said this problem is known and i need a driver with a digital signature.So they can't solve my problem and i should ask the manufactor for a solution for this problem.They said also that the Educake, Zero and One has'nt a hardware mailfunction.This problem occured if the VID is 0000.

Now my question : What can i do to solve this problem?

LG Guido

2016 年 01 月 13 日
09:58:54
cucubutter
Moderator
Forum Posts: 84
Member Since:
2014 年 04 月 10 日
Offline

Can your PC recognized Educake, Zero and One when use sysimage?
You have finished that update 86Duino system firmware?

2016 年 01 月 13 日
14:35:34
guigra
Moderator
Forum Posts: 17
Member Since:
2014 年 02 月 15 日
Offline

Hi cucubutter,

thanks for your replay.Yes i had finished the compled sysimage.My PC reconized Educake, Zero and One after the sysimage.But if i make a powershutdown and then turn the power on the same error occurred again.I had tested this procedure also under Windwos XP 32bit of an old Compaq E500 (15 years old) but the same error.I have now clue why this happendConfused

LG Guido

2016 年 01 月 13 日
15:55:49
cucubutter
Moderator
Forum Posts: 84
Member Since:
2014 年 04 月 10 日
Offline

Hi LG Guido

Oh, it is strange.
if i make a powershutdown and then turn the power on the same error occurred again <= It is mean PC or 86Duino?

cucubutter

2016 年 01 月 13 日
16:50:25
guigra
Moderator
Forum Posts: 17
Member Since:
2014 年 02 月 15 日
Offline

Hi cucubutter,

befor i shutdown the PC i switch off the external devices(Educake, Zero or One) and if i switch my PC on im waiting until my Windows is ready to work.After this i turn on the external devices (Educake, Zero or One).This bootsequenz is recommanded by microsoft and also
from the mainboard producer.

Guido

2016 年 01 月 14 日
17:28:44
cucubutter
Moderator
Forum Posts: 84
Member Since:
2014 年 04 月 10 日
Offline

Hi LG Guido

Maybe you need to install 86duino driver, see following document:
http://www.86duino.com/index.php?p=4220

cucubutter

2016 年 01 月 14 日
23:51:05
guigra
Moderator
Forum Posts: 17
Member Since:
2014 年 02 月 15 日
Offline

Hi cucubutter,

thanks for your anwser.I know this page but for MS Windows 10 64bit is no driver available.After a new start it seems that my Educake is death.There is no reaction if i turn Educake on (no recognizeing on Windows or other OS).After opening the Educake i rejected the main module and make some tests.The main module works very well and also the main modules from Zero and One. I think that the carrierboard from Educake has a problem .

Guido

2016 年 01 月 21 日
16:02:41
Android_Lin
Moderator
Forum Posts: 208
Member Since:
2014 年 04 月 01 日
Offline

Hi, Guido

I want to check whether the problem is created by PC or by 86Duino program:

1. Restore the SysImage to the micro-SD card, and then insert it to 86Duino, connect 86Duino with PC via USB wire, is it success to recognize 86Duino on Windows 10 64-bit?
2. If Step1 is yes, powerdown and poweron PC, and then connect 86Duino to PC again, is it still success to recognize 86Duino on Windows 10 64-bit?

Describe your result and i will provide more checking steps.

Android_Lin

2016 年 01 月 21 日
18:18:16
guigra
Moderator
Forum Posts: 17
Member Since:
2014 年 02 月 15 日
Offline
12

Hi Android_Lin

now i had made the first Step but the same result as befor.Windows 10 64bit can't recognized the 86Duino as an normal usb device but the following error message ocurred Error 43 : unknown usb device ( errror at request of a device discription).If i make the recomanded step 2 then Windows 10 64bit don't see 86Duino anymore.I have no clue why this happend.
Now at the last option i had downloaded the DuinoOS 1.1 and build the SD Card.I put this card in SD Slot from 86Duino Zero and connect the Zero with my PC to see what happend.Now Windows 10 64bit recognized the Zero as an serial usb device on COM 6.Then i opened Putty and DuinoOS runs very well.After this i had disconnected the Zero from the PC and remove the SD Card. Then i connected the Zero with my PC and the same error as above ocurred.This is strange but with the inserted SD Card with the DuinoOS 1.1 it runs without problems and the recognition with Windows 10 64 bit is also ready.

guigra

2016 年 01 月 22 日
23:16:21
Android_Lin
Moderator
Forum Posts: 208
Member Since:
2014 年 04 月 01 日
Offline

Hello, Guido

now i had made the first Step but the same result as befor.Windows 10 64bit can't recognized the 86Duino as an normal usb device but the following error message ocurred Error 43 : unknown usb device ( errror at request of a device discription).If i make the recomanded step 2 then Windows 10 64bit don't see 86Duino anymore.I have no clue why this happend.

Do you refer this tutorial to restore SysImage to SD card?

Now at the last option i had downloaded the DuinoOS 1.1 and build the SD Card.I put this card in SD Slot from 86Duino Zero and connect the Zero with my PC to see what happend.Now Windows 10 64bit recognized the Zero as an serial usb device on COM 6.Then i opened Putty and DuinoOS runs very well.After this i had disconnected the Zero from the PC and remove the SD Card. Then i connected the Zero with my PC and the same error as above ocurred.This is strange but with the inserted SD Card with the DuinoOS 1.1 it runs without problems and the recognition with Windows 10 64 bit is also ready.

Because the boot sequence on 86Duino is:

1. SD card
2. USB flash storage
3. Internal built-in flash

If you rebuild SD card and insert to 86Duino, 86Duino will boot from SD card, if remove SD card, 86Duino will boot from internal flash storage. Your condition shows that the system firmware in internal flash storage may be broken, try to restore the system firmware using SysImage.

Android_Lin

2016 年 01 月 22 日
23:27:00
guigra
Moderator
Forum Posts: 17
Member Since:
2014 年 02 月 15 日
Offline
14

Hi Android_Lin

yes i had refer this tutorial to restore SysImage.I followed it Step by Step and get everytime the same result.Confused

guigra

Forum Timezone: Asia/Taipei

Most Users Ever Online: 66

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Dinosaur: 27

leutenecker: 13

mrZagg: 10

lukeross: 8

tomka: 8

smeezekitty: 8

hippy: 8

Ekkehard: 8

UIdahoCIT: 8

blaxxun: 7

Member Stats:

Guest Posters: 0

Members: 1509

Moderators: 14

Admins: 5

Forum Stats:

Groups: 2

Forums: 10

Topics: 238

Posts: 1079

Newest Members: Carol Chou, Kai-Jung Chou, 1789, RegLiu, ameerawwad, asmanko, nekotwingo, ttronic, Davidpag, zaskia12

Moderators: Glaux: 70, uaa: 11, guigra: 17, asian55: 22, Android_Lin: 208, bcarroll: 12, cucubutter: 84, recycled-air: 12, stevemork: 16, zerozaber: 52, pongraczi: 20, George Andrews III: 56, poto: 11, garpastym: 20

Administrators: eveshih: 1, anthony: 31, viky6: 0, roboard: 135, hcl: 0